import re
regex = re.compile(r"^(class[^\S\n].*)((?:\n(?!class ).*)+)", flags=re.MULTILINE)
test_str = ("class friendly():\n"
" def __init__(x, y, z):\n"
" self.x = x\n"
" self.y = y\n"
" self.z = z\n\n"
" def printme(): \n"
" print(self.x)\n"
"class unfriendly():\n"
" def friendme():\n"
" assert self.x == self.y\n\n"
"class friendly():\n"
" def __init__(x, y, z):\n"
" self.x = x\n"
" self.y = y\n"
" self.z = z\n\n"
" def printme(): \n"
" print(self.x)\n\n"
"class unfriendly():\n"
" def friendme():\n"
" assert self.x == self.y\n\n"
"class friendly():\n"
" def __init__(x, y, z):\n"
" self.x = x\n"
" self.y = y\n"
" self.z = z\n\n"
" def printme(): \n"
" print(self.x)\n\n\n\n"
"class unfriendly():\n"
" def friendme():\n"
" assert self.x == self.y")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")