import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:((?>.{1,25}(?:[^\\r\\n]{1,5}(?=\\r?\\n|$)|(?<=[^\\S\\r\\n])[^\\S\\r\\n]?|(?=\\r?\\n)|$|[^\\S\\r\\n]))|.{1,25})(?:\\r?\\n)?|(?:\\r?\\n|$))";
final String string = "Aim for the moon. If you miss, you may hit a star. – Clement Stone\n"
+ "Nothing about us without us";
final String subst = "$1\\r\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}