const regex = /(?:((?>.{1,25}(?:[^\r\n]{1,5}(?=\r?\n|$)|(?<=[^\S\r\n])[^\S\r\n]?|(?=\r?\n)|$|[^\S\r\n]))|.{1,25})(?:\r?\n)?|(?:\r?\n|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:((?>.{1,25}(?:[^\\r\\n]{1,5}(?=\\r?\\n|$)|(?<=[^\\S\\r\\n])[^\\S\\r\\n]?|(?=\\r?\\n)|$|[^\\S\\r\\n]))|.{1,25})(?:\\r?\\n)?|(?:\\r?\\n|$))', 'gm')
const str = `Aim for the moon. If you miss, you may hit a star. – Clement Stone
Nothing about us without us`;
const subst = `$1\r\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);