$re = '/(?:((?>.{1,25}(?:[^\r\n]{1,5}(?=\r?\n|$)|(?<=[^\S\r\n])[^\S\r\n]?|(?=\r?\n)|$|[^\S\r\n]))|.{1,25})(?:\r?\n)?|(?:\r?\n|$))/m';
$str = 'Aim for the moon. If you miss, you may hit a star. – Clement Stone
Nothing about us without us';
$subst = "$1\r\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;