#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:(?:0[13578]|1[02])(\/)31)\1|(?:(?:0[1,3-9]|1[0-2])(\/)(?:29|30)\2))(?:(?:19|[2-9]\d)\d{2})$|^(?:02(\/)29\3(?:(?:(?:19|20)(?:[02468][048]|[13579][26]))))$|^(?:(?:0[1-9])|(?:1[0-2]))(\/)(?:0[1-9]|1\d|2[0-8])\4(?:(?:19|[0-9]\d)?\d{2})$"
Local $sString = "01/01/2019" & @CRLF & _
"02/29/2020" & @CRLF & _
"01/31/00" & @CRLF & _
"02/29/2000" & @CRLF & _
"03/31/2019" & @CRLF & _
"02/29/2020" & @CRLF & _
"07/23/1999" & @CRLF & _
"07/31/1999" & @CRLF & _
"07/28/1999" & @CRLF & _
"07/21/1999" & @CRLF & _
"07/05/1964" & @CRLF & _
"07/21/2000" & @CRLF & _
"02/29/1900" & @CRLF & _
"06/05/1999" & @CRLF & _
"05/05/1999" & @CRLF & _
"04/04/1999" & @CRLF & _
"03/03/1999" & @CRLF & _
"02/02/1999" & @CRLF & _
"02/29/1996" & @CRLF & _
"02/29/2000" & @CRLF & _
"01/01/1954" & @CRLF & _
"01/01/1985" & @CRLF & _
"03/31/2019" & @CRLF & _
"01/29/2010" & @CRLF & _
"10/21/1967"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")