re = /^(?:(?:(?:0[13578]|1[02])(\/)31)\1|(?:(?:0[1,3-9]|1[0-2])(\/)(?:29|30)\2))(?:(?:19|[2-9]\d)\d{2})$|^(?:02(\/)29\3(?:(?:(?:19|20)(?:[02468][048]|[13579][26]))))$|^(?:(?:0[1-9])|(?:1[0-2]))(\/)(?:0[1-9]|1\d|2[0-8])\4(?:(?:19|[0-9]\d)?\d{2})$/m
str = '01/01/2019
02/29/2020
01/31/00
02/29/2000
03/31/2019
02/29/2020
07/23/1999
07/31/1999
07/28/1999
07/21/1999
07/05/1964
07/21/2000
02/29/1900
06/05/1999
05/05/1999
04/04/1999
03/03/1999
02/02/1999
02/29/1996
02/29/2000
01/01/1954
01/01/1985
03/31/2019
01/29/2010
10/21/1967'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end