import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(?:0[13578]|1[02])(\\/)31)\\1|(?:(?:0[1,3-9]|1[0-2])(\\/)(?:29|30)\\2))(?:(?:19|[2-9]\\d)\\d{2})$|^(?:02(\\/)29\\3(?:(?:(?:19|20)(?:[02468][048]|[13579][26]))))$|^(?:(?:0[1-9])|(?:1[0-2]))(\\/)(?:0[1-9]|1\\d|2[0-8])\\4(?:(?:19|[0-9]\\d)?\\d{2})$";
final String string = "01/01/2019\n"
+ "02/29/2020\n"
+ "01/31/00\n"
+ "02/29/2000\n"
+ "03/31/2019\n"
+ "02/29/2020\n"
+ "07/23/1999\n"
+ "07/31/1999\n"
+ "07/28/1999\n"
+ "07/21/1999\n"
+ "07/05/1964\n"
+ "07/21/2000\n"
+ "02/29/1900\n"
+ "06/05/1999\n"
+ "05/05/1999\n"
+ "04/04/1999\n"
+ "03/03/1999\n"
+ "02/02/1999\n"
+ "02/29/1996\n"
+ "02/29/2000\n"
+ "01/01/1954\n"
+ "01/01/1985\n"
+ "03/31/2019\n"
+ "01/29/2010\n"
+ "10/21/1967";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}