#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)<\? # opening tag" & @CRLF & _
"[^?\/]* # all that is not a ? or a /" & @CRLF & _
"(?:" & @CRLF & _
" \/ # a slash:" & @CRLF & _
" (?:" & @CRLF & _
" (?![\/*]) [^?\/]* # - not followed by a slash or a *" & @CRLF & _
" |" & @CRLF & _
" \/.*(?:\n[^?\/]*)? # - that starts a single line comment" & @CRLF & _
" | " & @CRLF & _
" \* # - that starts a multiline comment" & @CRLF & _
" [^*]* (?:\*+(?!\/)[^*]*)* # (comment content)" & @CRLF & _
" (?:\*\/ [^?\/]* | $) # */ is optional" & @CRLF & _
" )" & @CRLF & _
" |" & @CRLF & _
" \?(?!>) [^?\/]* # a ? not followed by a >" & @CRLF & _
")*" & @CRLF & _
"(?:\?>|$) # optional closing tag ?>"
Local $sString = "<? /* hello */ ?>" & @CRLF & _
"html" & @CRLF & _
"<? /* world*/ ?>" & @CRLF & _
"" & @CRLF & _
"<? /// ?>" & @CRLF & _
"dfgdfgdfg?>" & @CRLF & _
"" & @CRLF & _
"<? /* ?> */ ?>" & @CRLF & _
"" & @CRLF & _
"<? /* unclosed " & @CRLF & _
" multiline" & @CRLF & _
" comment" & @CRLF & _
" works until the end of the string "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")