package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<\? # opening tag
[^?\/]* # all that is not a ? or a /
(?:
\/ # a slash:
(?:
(?![\/*]) [^?\/]* # - not followed by a slash or a *
|
\/.*(?:\n[^?\/]*)? # - that starts a single line comment
|
\* # - that starts a multiline comment
[^*]* (?:\*+(?!\/)[^*]*)* # (comment content)
(?:\*\/ [^?\/]* | $) # */ is optional
)
|
\?(?!>) [^?\/]* # a ? not followed by a >
)*
(?:\?>|$) # optional closing tag ?>`)
var str = `<? /* hello */ ?>
html
<? /* world*/ ?>
<? /// ?>
dfgdfgdfg?>
<? /* ?> */ ?>
<? /* unclosed
multiline
comment
works until the end of the string `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}