import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\? # opening tag\n"
+ "[^?\\/]* # all that is not a ? or a /\n"
+ "(?:\n"
+ " \\/ # a slash:\n"
+ " (?:\n"
+ " (?![\\/*]) [^?\\/]* # - not followed by a slash or a *\n"
+ " |\n"
+ " \\/.*(?:\\n[^?\\/]*)? # - that starts a single line comment\n"
+ " | \n"
+ " \\* # - that starts a multiline comment\n"
+ " [^*]* (?:\\*+(?!\\/)[^*]*)* # (comment content)\n"
+ " (?:\\*\\/ [^?\\/]* | $) # */ is optional\n"
+ " )\n"
+ " |\n"
+ " \\?(?!>) [^?\\/]* # a ? not followed by a >\n"
+ ")*\n"
+ "(?:\\?>|$) # optional closing tag ?>";
final String string = "<? /* hello */ ?>\n"
+ "html\n"
+ "<? /* world*/ ?>\n\n"
+ "<? /// ?>\n"
+ "dfgdfgdfg?>\n\n"
+ "<? /* ?> */ ?>\n\n"
+ "<? /* unclosed \n"
+ " multiline\n"
+ " comment\n"
+ " works until the end of the string ";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}