#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)var\d+(?:(?!var\d).)*?secondVar"
Local $sString = "var12.1" & @CRLF & _
"a" & @CRLF & _
"a" & @CRLF & _
"dsa" & @CRLF & _
"" & @CRLF & _
"88" & @CRLF & _
"123!!!" & @CRLF & _
"secondVar12.1" & @CRLF & _
"var12.1" & @CRLF & _
"a" & @CRLF & _
"a" & @CRLF & _
"dsa" & @CRLF & _
"" & @CRLF & _
"88" & @CRLF & _
"123!!!" & @CRLF & _
"secondVar12.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")