using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"var\d+(?:(?!var\d).)*?secondVar";
string input = @"var12.1
a
a
dsa
88
123!!!
secondVar12.1
var12.1
a
a
dsa
88
123!!!
secondVar12.1";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}