import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "var\\d+(?:(?!var\\d).)*?secondVar";
final String string = "var12.1\n"
+ "a\n"
+ "a\n"
+ "dsa\n\n"
+ "88\n"
+ "123!!!\n"
+ "secondVar12.1\n"
+ "var12.1\n"
+ "a\n"
+ "a\n"
+ "dsa\n\n"
+ "88\n"
+ "123!!!\n"
+ "secondVar12.1";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}