#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((https?:\/\/)?(www.)?soundcloud\.com\/[^\"]*)\S*\1"
Local $sString = "<a href="https://soundcloud.com/worriedaboutsatan/live-in-manchester-19th-march-2015">https://soundcloud.com/worriedaboutsatan/live-in-manchester-19th-march-2015</a>" & @CRLF & _
"" & @CRLF & _
"https://soundcloud.com/worriedaboutsatan/live-in-manchester-19th-march-2015" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")