const regex = /((https?:\/\/)?(www.)?soundcloud\.com\/[^\"]*)\S*\1/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((https?:\\\/\\\/)?(www.)?soundcloud\\.com\\\/[^\\"]*)\\S*\\1', '')
const str = `<a href="https://soundcloud.com/worriedaboutsatan/live-in-manchester-19th-march-2015">https://soundcloud.com/worriedaboutsatan/live-in-manchester-19th-march-2015</a>
https://soundcloud.com/worriedaboutsatan/live-in-manchester-19th-march-2015
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}