import Foundation
let pattern = #"((https?:\/\/)?(www.)?soundcloud\.com\/[^\"]*)\S*\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<a href="https://soundcloud.com/worriedaboutsatan/live-in-manchester-19th-march-2015">https://soundcloud.com/worriedaboutsatan/live-in-manchester-19th-march-2015</a>
https://soundcloud.com/worriedaboutsatan/live-in-manchester-19th-march-2015
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}