package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{4})(?:.*((?:[1-9]|1[0-9]|2[0-4]) hour(?: 30 minutes)?))?`)
var str = `Pay for zone 1234 for 1 hour
Pay for zone 4567
Pay for zone 1234 for 1 hour 30 minutes`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}