const regex = new RegExp('(\\d{4})(?:.*((?:[1-9]|1[0-9]|2[0-4]) hour(?: 30 minutes)?))?', 'gm')
const str = `Pay for zone 1234 for 1 hour
Pay for zone 4567
Pay for zone 1234 for 1 hour 30 minutes`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}