import re
regex = re.compile(r"(\d{4})(?:.*((?:[1-9]|1[0-9]|2[0-4]) hour(?: 30 minutes)?))?", flags=re.MULTILINE)
test_str = ("Pay for zone 1234 for 1 hour\n"
"Pay for zone 4567\n"
"Pay for zone 1234 for 1 hour 30 minutes")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")