$re = '/\"(.*?)\"/m';
$str = ' "Banco do Brasil",
"Santander",
"Caixa Econômica Federal",
"Itaú",
"Bradesco",
"Outro"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);