re = /\"(.*?)\"/m
str = ' "Banco do Brasil",
"Santander",
"Caixa Econômica Federal",
"Itaú",
"Bradesco",
"Outro"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end