using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"animals\.(?!elephant)\w+";
string input = @"animals.fox
=> Result: animals.fox
animals.kitten
=> Result: animals.kitten
animals.elephant ";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}