$re = '/animals\.(?!elephant)\w+/';
$str = 'animals.fox
=> Result: animals.fox
animals.kitten
=> Result: animals.kitten
animals.elephant ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);