import re
regex = re.compile(r"^(?=.{14}$).{8}(.*).$|^.*$", flags=re.MULTILINE)
test_str = ("abcdefghipolhg\n"
"aksjbjkshadjshdjhakjdhkj\n"
"asdasd")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)