re = /^(?=.{14}$).{8}(.*).$|^.*$/m
str = 'abcdefghipolhg
aksjbjkshadjshdjhakjdhkj
asdasd'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result