package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(0{1,5})(4411)([0-9]{1,6})`)
var str = `0441145678`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}