const regex = /(0{1,5})(4411)([0-9]{1,6})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(0{1,5})(4411)([0-9]{1,6})', 'gm')
const str = `0441145678`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}