$re = '/(0{1,5})(4411)([0-9]{1,6})/m';
$str = '0441145678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);