package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\w-]*tea['\w-]*`)
var str = `teatime, let's have milk-tea at "tea's finest"`
var substitution = "<b>$0</b>"
fmt.Println(re.ReplaceAllString(str, substitution))
}