import Foundation
let pattern = #"[\w-]*tea['\w-]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"teatime, let's have milk-tea at "tea's finest""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<b>$0</b>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)