$re = '/[\w-]*tea[\'\w-]*/';
$str = 'teatime, let\'s have milk-tea at "tea\'s finest"';
$subst = "<b>$0</b>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;