#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)input{([\s\S]*?)^}"
Local $sString = "input{" & @CRLF & _
" stdin {" & @CRLF & _
" type => "stdin-type"" & @CRLF & _
" }" & @CRLF & _
" file {" & @CRLF & _
" type => "file"" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"output {" & @CRLF & _
" stdout { }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"input{" & @CRLF & _
" stdin {" & @CRLF & _
" type => "stdin-type"" & @CRLF & _
" }" & @CRLF & _
" file {" & @CRLF & _
" type => "file"" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"output {" & @CRLF & _
" stdout { }" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")