$re = '/input{([\s\S]*?)^}/m';
$str = 'input{
stdin {
type => "stdin-type"
}
file {
type => "file"
}
}
output {
stdout { }
}
input{
stdin {
type => "stdin-type"
}
file {
type => "file"
}
}
output {
stdout { }
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);