using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"input{([\s\S]*?)^}";
string input = @"input{
stdin {
type => ""stdin-type""
}
file {
type => ""file""
}
}
output {
stdout { }
}
input{
stdin {
type => ""stdin-type""
}
file {
type => ""file""
}
}
output {
stdout { }
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}