const regex = /:\s+([a-zA-Z\d'-,\s]*?)\s\s+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(':\\s+([a-zA-Z\\d\'-,\\s]*?)\\s\\s+', '')
const str = `Billing Address:
Harry Smith
3423 My Lane
SOME CITY, CA 94105
United States
Some more text`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}