// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r":\s+([a-zA-Z\d'-,\s]*?)\s\s+").unwrap();
let string = "Billing Address:
Harry Smith
3423 My Lane
SOME CITY, CA 94105
United States
Some more text";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}