import Foundation
let pattern = #":\s+([a-zA-Z\d'-,\s]*?)\s\s+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Billing Address:
Harry Smith
3423 My Lane
SOME CITY, CA 94105
United States
Some more text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}