#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^ERROR on (?:(?!Network connection reset).)*$"
Local $sString = "ERROR on Server1: Network connection reset." & @CRLF & _
" DETAIL: The client is gone." & @CRLF & _
"ERROR on Server2: Network connection reset." & @CRLF & _
" DETAIL: The client is gone." & @CRLF & _
"ERROR on Server1: Network connection reset." & @CRLF & _
" DETAIL: The client is gone." & @CRLF & _
"ERROR on Server1: Null Pointer Error." & @CRLF & _
" DETAIL: Object 'Cart' does not exists." & @CRLF & _
" STACKTRACE: " & @CRLF & _
" at UpdateCart function" & @CRLF & _
" at AddProducttoCart function" & @CRLF & _
"ERROR on Server2: Network connection reset." & @CRLF & _
" DETAIL: The client is gone." & @CRLF & _
"ERROR on Server2: IO Error" & @CRLF & _
" DETAIL: The resource on URL (www.example.com/data.xls) does not exists." & @CRLF & _
"ERROR on Server2: Network connection reset." & @CRLF & _
" DETAIL: The client is gone."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")