import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ERROR on (?:(?!Network connection reset).)*$";
final String string = "ERROR on Server1: Network connection reset.\n"
+ " DETAIL: The client is gone.\n"
+ "ERROR on Server2: Network connection reset.\n"
+ " DETAIL: The client is gone.\n"
+ "ERROR on Server1: Network connection reset.\n"
+ " DETAIL: The client is gone.\n"
+ "ERROR on Server1: Null Pointer Error.\n"
+ " DETAIL: Object 'Cart' does not exists.\n"
+ " STACKTRACE: \n"
+ " at UpdateCart function\n"
+ " at AddProducttoCart function\n"
+ "ERROR on Server2: Network connection reset.\n"
+ " DETAIL: The client is gone.\n"
+ "ERROR on Server2: IO Error\n"
+ " DETAIL: The resource on URL (www.example.com/data.xls) does not exists.\n"
+ "ERROR on Server2: Network connection reset.\n"
+ " DETAIL: The client is gone.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}