# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^ERROR on (?:(?!Network connection reset).)*$"
test_str = ("ERROR on Server1: Network connection reset.\n"
" DETAIL: The client is gone.\n"
"ERROR on Server2: Network connection reset.\n"
" DETAIL: The client is gone.\n"
"ERROR on Server1: Network connection reset.\n"
" DETAIL: The client is gone.\n"
"ERROR on Server1: Null Pointer Error.\n"
" DETAIL: Object 'Cart' does not exists.\n"
" STACKTRACE: \n"
" at UpdateCart function\n"
" at AddProducttoCart function\n"
"ERROR on Server2: Network connection reset.\n"
" DETAIL: The client is gone.\n"
"ERROR on Server2: IO Error\n"
" DETAIL: The resource on URL (www.example.com/data.xls) does not exists.\n"
"ERROR on Server2: Network connection reset.\n"
" DETAIL: The client is gone.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.