const regex = /(http[s]?)\:\/\/([aZ09-_]*?\.)?([aZ09-_]{2,}\.)([\w\.]{2,5})/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http[s]?)\\:\\\/\\\/([aZ09-_]*?\\.)?([aZ09-_]{2,}\\.)([\\w\\.]{2,5})', 'gmi')
const str = `http://tonton.google.fr
https://www.google.fr
http://www.google.co.uk
https://paulrad.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}