$re = '/(http[s]?)\:\/\/([aZ09-_]*?\.)?([aZ09-_]{2,}\.)([\w\.]{2,5})/mi';
$str = 'http://tonton.google.fr
https://www.google.fr
http://www.google.co.uk
https://paulrad.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);