re = /(http[s]?)\:\/\/([aZ09-_]*?\.)?([aZ09-_]{2,}\.)([\w\.]{2,5})/mi
str = 'http://tonton.google.fr
https://www.google.fr
http://www.google.co.uk
https://paulrad.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end