import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:([^<]*)|<(?!\\/p)(?:[^>=]|='[^']*'|=\"[^\"]*\"|=[^'\"][^\\s>]*)*>)\n";
final String string = "<p class=bodyDC style='text-indent:12.0pt'><span style='font-size:14.0pt;\n"
+ "mso-bidi-font-size:10.0pt'>We have no need to fear the future." So said\n"
+ "bishop-elect H. George Anderson at a news conference immediately following his election as \n"
+ "bishop of the <span onmouseover=\" <span>not the droids you're looking for</span> \">Evangelical Lutheran Church in America. "[The\n"
+ "future] belongs to God, untouched by human hands." At the beginning of a\n"
+ "new ministry of leadership and pastoral oversight, such words from a bishop are\n"
+ "obviously designed to project confidence and a profound sense of trust in the\n"
+ "mission of the Church. They are words designed to inspire and empower the\n"
+ "people of God for ministry.<o:p></o:p></span>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}