re = /(?:([^<]*)|<(?!\/p)(?:[^>=]|='[^']*'|="[^"]*"|=[^'"][^\s>]*)*>)
/mix
str = '<p class=bodyDC style=\'text-indent:12.0pt\'><span style=\'font-size:14.0pt;
mso-bidi-font-size:10.0pt\'>We have no need to fear the future." So said
bishop-elect H. George Anderson at a news conference immediately following his election as
bishop of the <span onmouseover=" <span>not the droids you\'re looking for</span> ">Evangelical Lutheran Church in America. "[The
future] belongs to God, untouched by human hands." At the beginning of a
new ministry of leadership and pastoral oversight, such words from a bishop are
obviously designed to project confidence and a profound sense of trust in the
mission of the Church. They are words designed to inspire and empower the
people of God for ministry.<o:p></o:p></span>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end