#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*(?:\+?(\d{1,3}))?[-. (]*(\d{3})[-. )]*(\d{3})[-. ]*(\d{4})(?: ?x(\d+))?\s*$"
Local $sString = "18005551234" & @CRLF & _
"1 800 555 1234" & @CRLF & _
"+1 800 555-1234" & @CRLF & _
"+86 800 555 1234" & @CRLF & _
"1-800-555-1234" & @CRLF & _
"1 (800) 555-1234" & @CRLF & _
"(800)555-1234" & @CRLF & _
"(800) 555-1234" & @CRLF & _
"(800)5551234" & @CRLF & _
"800-555-1234" & @CRLF & _
"800.555.1234" & @CRLF & _
"800 555 1234x5678" & @CRLF & _
"8005551234 x5678" & @CRLF & _
"1 800 555-1234" & @CRLF & _
"1----800----555-1234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")