# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\s*(?:\+?(\d{1,3}))?[-. (]*(\d{3})[-. )]*(\d{3})[-. ]*(\d{4})(?: ?x(\d+))?\s*$"
test_str = ("18005551234\n"
"1 800 555 1234\n"
"+1 800 555-1234\n"
"+86 800 555 1234\n"
"1-800-555-1234\n"
"1 (800) 555-1234\n"
"(800)555-1234\n"
"(800) 555-1234\n"
"(800)5551234\n"
"800-555-1234\n"
"800.555.1234\n"
"800 555 1234x5678\n"
"8005551234 x5678\n"
"1 800 555-1234\n"
"1----800----555-1234")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.