import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?:\\+?(\\d{1,3}))?[-. (]*(\\d{3})[-. )]*(\\d{3})[-. ]*(\\d{4})(?: ?x(\\d+))?\\s*$";
final String string = "18005551234\n"
+ "1 800 555 1234\n"
+ "+1 800 555-1234\n"
+ "+86 800 555 1234\n"
+ "1-800-555-1234\n"
+ "1 (800) 555-1234\n"
+ "(800)555-1234\n"
+ "(800) 555-1234\n"
+ "(800)5551234\n"
+ "800-555-1234\n"
+ "800.555.1234\n"
+ "800 555 1234x5678\n"
+ "8005551234 x5678\n"
+ "1 800 555-1234\n"
+ "1----800----555-1234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}