const regex = /(#[A-Z](-\d+){3})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(#[A-Z](-\\d+){3})', '')
const str = `Your order #Q-1-111-1111. Bill amount is \$100.50`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}