re = /(#[A-Z](-\d+){3})/
str = 'Your order #Q-1-111-1111. Bill amount is $100.50'
# Print the match result
str.match(re) do |match|
puts match.to_s
end